Skip to main content
VulnerabilityPublished Updated

CVE-2024-9000: lunary-ai/lunary · Missing Authorization

Affects lunary-ai/lunarySource CVE Database V5

0

Not known to be exploited · CVSS 7.1 High : upgrade to 1.4.26 soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.4.26
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Mar 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade lunary-ai/lunary to 1.4.26.

Affected software

ProductAffectedFixed in
GitHublunary-ai/lunarypkg:github/lunary-ai/lunaryOther threatsAffected
  • <1.4.26
Fixed in
  • 1.4.26

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2024-9000, organizations should immediately upgrade lunary-ai/lunary to version 1.4.26 or later where the vulnerability is patched. If upgrading is not immediately feasible, implement strict access controls to limit who can authenticate and access the checklists.post() endpoint, ideally restricting it to trusted administrators or service accounts. Employ application-layer firewalls or API gateways to monitor and block unauthorized modification attempts. Implement logging and alerting on checklist creation and modification activities to detect suspicious behavior. Additionally, validate and enforce uniqueness of the slug field at the application or database level to prevent overwriting existing checklists. Conduct regular audits of checklist data integrity and review user permissions to minimize the risk of insider exploitation. Finally, educate users about the risks of credential compromise and enforce strong authentication mechanisms such as multi-factor authentication to reduce the likelihood of unauthorized access.

Description

In lunary-ai/lunary before version 1.4.26, the checklists.post() endpoint allows users to create or modify checklists without validating whether the user has proper permissions. This missing access control permits unauthorized users to create checklists, bypassing intended permission checks. Additionally, the endpoint does not validate the uniqueness of the slug field when creating a new checklist, allowing an attacker to spoof existing checklists by reusing the slug of an already-existing checklist. This can lead to significant data integrity issues, as legitimate checklists can be replaced with malicious or altered data.

References

Community reviews

Loading reviews…