Skip to main content
CVE-2024-9407VulnerabilityPublished Updated

CVE-2024-9407: podman · Improper Input Validation

Affects podmanSource CVE Database V5

0

Not known to be exploited · CVSS 4.7 Medium : upgrade to 5.2.4 when convenient.

Data as of 26 Oct 2026, 08:45 UTC

CVSS 3.1 base score
4.7Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.2.4, 1.37.4
CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:U/C:H/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Oct 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade podman to 5.2.4; buildah to 1.37.4.

Affected software

ProductAffectedFixed in
podmanAffected
  • <5.2.4
Fixed in
  • 5.2.4
buildahAffected
  • <1.37.4
Fixed in
  • 1.37.4
GitHubpodmanpkg:github/podmanOther threatsAffected
  • <5.2.4
Fixed in
  • 5.2.4
GitHubbuildahpkg:github/buildahOther threatsAffected
  • <1.37.4
Fixed in
  • 1.37.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2024-9407, organizations should immediately review and restrict access to Docker build environments, ensuring only trusted users have high privileges required to exploit this vulnerability. Implement strict access controls and auditing on build servers and hosts running Docker. Avoid using untrusted or external Dockerfiles that could exploit the RUN --mount bind-propagation option. If you cannot patch yet, consider disabling or limiting the use of the RUN --mount instruction with bind-propagation in Dockerfiles. Employ container build isolation techniques such as dedicated build hosts or sandboxed environments to reduce risk. Monitor file system access and SELinux logs for unusual relabeling or mount activities. Additionally, educate developers and DevOps teams about the risks of improper mount options and enforce secure coding and build practices. Consider using alternative container build tools or methods that do not expose this vulnerability if immediate patching is not possible.

Description

A vulnerability exists in the bind-propagation option of the Dockerfile RUN --mount instruction. The system does not properly validate the input passed to this option, allowing users to pass arbitrary parameters to the mount instruction. This issue can be exploited to mount sensitive directories from the host into a container during the build process and, in some cases, modify the contents of those mounted files. Even if SELinux is used, this vulnerability can bypass its protection by allowing the source directory to be relabeled to give the container access to host files.

References

Community reviews

Loading reviews…