Skip to main content
VulnerabilityPublished

CVE-2025-10357: Simple SEO (WordPress plugin) · Cross-Site Scripting (XSS)

Affects Simple SEO (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 6.1 Medium.

Data as of 26 Oct 2026, 13:47 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Simple SEOAffected
  • =0
Fixed in–

AI-suggested

  1. Immediately update the Simple SEO WordPress plugin to version 2.0.32 or later, where the vulnerability is fixed.
  2. Audit and restrict contributor-level user permissions to the minimum necessary, ensuring that only trusted users have such access.
  3. Implement Web Application Firewall (WAF) rules to detect and block common XSS payloads targeting the affected plugin parameters.
  4. Enable Content Security Policy (CSP) headers to reduce the impact of potential XSS by restricting script execution sources.
  5. Regularly review and sanitize user-generated content, especially from contributors, before publishing.
  6. Monitor logs and user activity for unusual behavior indicative of exploitation attempts.
  7. Educate site administrators and content contributors about the risks of XSS and safe content practices.
  8. Consider using security plugins that provide additional input validation and output escaping for WordPress.
  9. Test the website after updates to ensure no residual vulnerabilities remain.
  10. Maintain a robust backup and incident response plan to quickly recover from any successful attacks.

Description

CVE-2025-10357 is a medium-severity Cross-Site Scripting (XSS) vulnerability in the Simple SEO WordPress plugin versions before 2.0.32. It arises because the plugin fails to properly sanitize and escape certain parameters when rendering them on pages. This flaw allows users with as low a privilege as the contributor role to inject malicious scripts, potentially affecting other users who view the compromised content. The vulnerability requires user interaction and network access but no elevated privileges beyond contributor. Although no known exploits are currently reported in the wild, the vulnerability's scope includes all WordPress sites using affected versions of Simple SEO. European organizations using this plugin could face risks of session hijacking, defacement, or phishing attacks. Mitigation involves promptly updating the plugin to version 2.0.

References

Community reviews

Loading reviews…