CVE-2025-1040: significant-gravitas/autogpt · Improper Neutralization of Special Elements Used in a Template Engine
Affects significant-gravitas/autogptSource CVE Database V5
Not known to be exploited · CVSS 8.8 High · fixed in 0.4.0 : patch significant-gravitas/autogpt soon.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 1.7% chance of exploitation in 30 days – higher than 77% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.4.0
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 20 Mar 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubsignificant-gravitas/autogptpkg:github/significant-gravitas/autogptOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Immediate upgrade to AutoGPT version 0.4.0 or later is the primary mitigation step, as it contains the patch addressing the SSTI vulnerability. Until upgrade is possible, organizations should restrict network access to AutoGPT instances, ideally isolating them within secure environments. Implement strict input validation and sanitization on all user-supplied data before it reaches the template engine. Employ sandboxing techniques or use safer templating configurations that disable code execution features in Jinja2. Monitor logs for suspicious template expressions or unexpected command executions. Conduct thorough code reviews and penetration testing focused on template injection vectors. Additionally, enforce the principle of least privilege for accounts running AutoGPT to limit potential damage from exploitation.
Description
AutoGPT versions 0.3.4 and earlier are vulnerable to a Server-Side Template Injection (SSTI) that could lead to Remote Code Execution (RCE). The vulnerability arises from the improper handling of user-supplied format strings in the `AgentOutputBlock` implementation, where malicious input is passed to the Jinja2 templating engine without adequate security measures. Attackers can exploit this flaw to execute arbitrary commands on the host system. The issue is fixed in version 0.4.0.