CVE-2025-10406: BlindMatrix e-Commerce (WordPress plugin) · Path Traversal
Affects BlindMatrix e-Commerce (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 5.5 Medium · fixed in 3.1 : update BlindMatrix e-Commerce (WordPress plugin) when convenient.
Data as of 26 Oct 2026, 12:54 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.1
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 15 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| BlindMatrix e-Commerce | Affected
| Fixed in– |
AI-suggested
- Upgrade the BlindMatrix e-Commerce plugin to version 3.1 or later as soon as it becomes available, as this version addresses the path traversal vulnerability.
- Restrict contributor-level permissions to trusted users only and regularly audit user roles to minimize the risk of insider threats.
- Implement strict input validation and sanitization for all shortcode attributes, ensuring that path inputs cannot traverse directories or include unintended files.
- Deploy Web Application Firewalls (WAFs) with rules specifically designed to detect and block path traversal attempts targeting WordPress plugins.
- Monitor logs for suspicious include function calls or unusual file access patterns indicative of LFI exploitation attempts.
- Consider isolating WordPress installations and limiting file system permissions to prevent unauthorized file access beyond the web root.
- Educate site administrators and developers about secure coding practices and the risks associated with improper input validation.
- Apply regular vulnerability scanning and penetration testing focused on WordPress plugins to detect similar issues proactively.
Description
The BlindMatrix e-Commerce WordPress plugin before 3.1 does not validate some shortcode attributes before using them to generate paths passed to include function/s, allowing any authenticated users, such as contributors, to perform LFI attacks.