CVE-2025-10493: Chained Quiz (WordPress plugin) · Insecure Direct Object Reference
Affects Chained Quiz (WordPress plugin)Source CVE Database V5
Public exploit available (Exploit-DB) · CVSS 5.3 Medium · fixed in 1.3.4 : patch Chained Quiz (WordPress plugin) as a priority.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.9% chance of exploitation in 30 days – higher than 59% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.3.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:NExploitation evidence
t = 0 is the CVE’s publication on cve.org
Disclosed: evidence found.
CVE published 18 Sep 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: evidence found.
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
Timeline
CVE ID reserved
by Wordfence
, 3 days before disclosure
CVE published
on cve.org
, t = 0
In Threat Radar
record ingested
, 7 hours after disclosure
First Exploit-DB entry (opens in a new tab)
Chained Quiz 1.3.5 - Unauthenticated Insecure Direct Object Reference via Cookie
, 98 days after disclosure
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| prasunsen Chained Quiz | Affected
| Fixed in– |
AI-suggested
Partial patches exist in versions 1.3.4 and 1.3.5, but the full remediation status is not confirmed. Users should upgrade to the latest plugin version once a complete fix is released.
Description
The Chained Quiz plugin for WordPress is vulnerable to Insecure Direct Object Reference in version 1.3.4 and below via the quiz submission and completion mechanisms due to missing validation on a user controlled key. This makes it possible for unauthenticated attackers to hijack and modify other users' quiz attempts by manipulating the chained_completion_id cookie value, allowing them to alter quiz answers, scores, and results of any user. The vulnerability was partially patched in versions 1.3.4 and 1.3.5.
References
- wordfence.com/threat-intel/vulnerabilities/id/1d8f6965-1fe3-4f24-bd6b-9026e91bc5db?source=cve (opens in a new tab)
- plugins.trac.wordpress.org/browser/chained-quiz/tags/1.3.3/controllers/quizzes.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/chained-quiz/tags/1.3.3/models/quiz.php (opens in a new tab)
- plugins.trac.wordpress.org/changeset/3362561/ (opens in a new tab)
- plugins.trac.wordpress.org/changeset/3362701/ (opens in a new tab)
- plugins.trac.wordpress.org/changeset/3362966/ (opens in a new tab)