CVE-2025-11158: Hitachi Vantara Pentaho Data Integration and Analytics · Missing Authorization
Affects Hitachi Vantara Pentaho Data Integration and AnalyticsSource CVE Database V5
Not known to be exploited · CVSS 9.1 Critical : upgrade to 10.2.0.6 as a priority.
Data as of 29 Oct 2026, 19:04 UTC
Contested
Critical score, yet low EPSS after six months- EPSS
- 0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 10.2.0.6
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 9 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Pentaho Data Integration and Analytics and com.hitachivantara/pentaho-data-integration-analytics to 10.2.0.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Hitachi VantaraPentaho Data Integration and Analytics | Affected
| Fixed in
|
Mavencom.hitachivantara/pentaho-data-integration-analyticspkg:maven/com.hitachivantara/pentaho-data-integration-analyticsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate CVE-2025-11158, organizations should prioritize upgrading to Hitachi Vantara Pentaho Data Integration and Analytics version 10.2.0.6 or later once the patch is released. Until then, implement strict access controls to limit report publishing privileges to trusted administrators only. Employ rigorous monitoring and auditing of report creation and publishing activities to detect anomalous or unauthorized Groovy script insertions. Disable or restrict the use of Groovy scripting in reports if feasible, or apply application-level controls to validate and sanitize scripts before execution. Network segmentation and application whitelisting can help contain potential exploitation impact. Additionally, enforce the principle of least privilege across the Pentaho environment to reduce the risk of privilege escalation. Regularly review and update security policies related to analytics platforms and conduct security awareness training for administrators. Finally, maintain up-to-date backups of analytics configurations and data to enable recovery in case of compromise.
Description
CVE-2025-11158 is a critical vulnerability in Hitachi Vantara Pentaho Data Integration and Analytics versions prior to 10.2.0.6, including 9.3.x and 8.3.x. The flaw arises from missing authorization controls on Groovy scripts embedded in new PRPT reports published by users. This lack of restriction allows attackers with certain privileges to insert arbitrary Groovy scripts, leading to remote code execution (RCE).