CVE-2025-11276: Rebuild · Cross Site Scripting
Affects RebuildSource CVE Database V5
Not known to be exploited · CVSS 5.1 Medium · fixed in 4.1.4 : update Rebuild when convenient.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.1.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:XExploitation evidence
Disclosed: evidence found.
CVE published 5 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Rebuild | Affected
| Fixed in– |
AI-suggested
Organizations should immediately upgrade Rebuild installations to version 4.1.4 or later to remediate the vulnerability. In addition to patching, implement robust input validation and output encoding on all user-supplied data, especially in comment and guestbook modules, to prevent injection of malicious scripts. Employ Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts in browsers. Regularly audit web application logs for suspicious comment submissions or unusual user activity indicative of attempted XSS exploitation. Educate users about the risks of clicking unknown links or interacting with untrusted content. Consider deploying web application firewalls (WAFs) with rules tuned to detect and block XSS payloads targeting the affected component. Finally, maintain an up-to-date inventory of Rebuild deployments across the organization to ensure no vulnerable instances remain unpatched.
Description
A security flaw has been discovered in Rebuild up to 4.1.3. Affected by this issue is some unknown functionality of the component Comment/Guestbook. Performing manipulation results in cross site scripting. It is possible to initiate the attack remotely. Upgrading to version 4.1.4 can resolve this issue. It is suggested to upgrade the affected component. According to the researcher the vendor has confirmed the flaw and fix in a private issue response.