Skip to main content
VulnerabilityPublished Updated

CVE-2025-11282: Frappe LMS · Cross-site Scripting

Affects Frappe LMSSource CVE Database V5

0

Mentioned vulnerabilities

Public exploit available · CVSS 4.8 Medium : upgrade to 2.35.0 as a priority.

Data as of 26 Oct 2026, 12:54 UTC

CVSS 4.0 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.35.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Frappe LMS to 2.35.0.

Affected software

ProductAffectedFixed in
Frappe LMSAffected
  • >=2.34.0 <2.35.0
  • =2.35.0
Fixed in
  • 2.35.0

AI-suggested

  1. Upgrade affected Frappe LMS instances to the latest version where this vulnerability is fully patched, even if release notes do not explicitly mention it, verifying with vendor advisories or security mailing lists.
  2. Implement strict input validation and output encoding on all user-supplied data within the LMS to prevent script injection.
  3. Employ Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts in browsers accessing the LMS.
  4. Educate users about the risks of clicking on suspicious links or interacting with unexpected LMS content to reduce the likelihood of triggering XSS payloads.
  5. Monitor LMS logs for unusual activities or repeated attempts to inject scripts, enabling early detection of exploitation attempts.
  6. If upgrading immediately is not feasible, consider deploying web application firewalls (WAFs) with rules targeting known XSS patterns specific to Frappe LMS.
  7. Engage with the vendor for confirmation of patch status and request detailed security advisories to ensure comprehensive remediation.
  8. Regularly audit and test the LMS environment for residual or new vulnerabilities, including penetration testing focused on XSS.

Description

A vulnerability was found in Frappe LMS 2.34.x/2.35.0. The impacted element is an unknown function of the component Incomplete Fix CVE-2025-55006. Performing a manipulation results in cross site scripting. Remote exploitation of the attack is possible. The exploit has been made public and could be used. The affected component should be upgraded. The vendor was informed early about a total of four security issues and confirmed that those have been fixed. However, the release notes on GitHub do not mention them.

References

Community reviews

Loading reviews…