Skip to main content
VulnerabilityPublished

CVE-2025-12414: Google Cloud Looker · Authentication Bypass by Spoofing

Affects Google Cloud LookerSource CVE Database V5

0

Not known to be exploited · CVSS 9.2 Critical.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/U:Amber

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Google Cloud LookerAffected
  • =0
Fixed in–

AI-suggested

European organizations using self-hosted Google Cloud Looker instances configured with OIDC authentication must immediately upgrade to one of the patched versions listed (24.12.100+, 24.18.193+, 25.0.69+, 25.6.57+, 25.8.39+, 25.10.22+, or 25.12.0+). Beyond patching, organizations should audit their OIDC configurations to ensure strict validation and normalization of identity attributes, particularly email addresses. Implement additional multi-factor authentication (MFA) layers where possible to reduce the risk of account takeover. Monitor authentication logs for unusual login patterns or anomalies indicative of spoofing attempts. Conduct regular penetration testing focused on identity and access management controls within Looker environments. Establish incident response plans specific to Looker account compromises, including rapid revocation of compromised credentials and forensic analysis. Educate administrators and users about the risks of identity spoofing and the importance of timely updates. Finally, consider network segmentation and least privilege principles to limit the impact of any potential compromise within analytics infrastructure.

Description

An attacker could take over a Looker account in a Looker instance configured with OIDC authentication, due to email address string normalization.Looker-hosted and Self-hosted were found to be vulnerable. This issue has already been mitigated for Looker-hosted. Self-hosted instances must be upgraded as soon as possible. This vulnerability has been patched in all supported versions of Self-hosted. The versions below have all been updated to protect from this vulnerability. You can download these versions at the Looker download page https://download.looker.com/ : * 24.12.100+ * 24.18.193+ * 25.0.69+ * 25.6.57+ * 25.8.39+ * 25.10.22+ * 25.12.0+

References

Community reviews

Loading reviews…