Skip to main content
CVE-2025-12472VulnerabilityPublished

CVE-2025-12472: Google Cloud Looker · Race Condition

Affects Google Cloud LookerSource CVE Database V5

0

Not known to be exploited · CVSS 7.1 High.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/U:Red

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Affected software

ProductAffectedFixed in
Google Cloud LookerAffected
  • =0
Fixed in–

AI-suggested

European organizations using self-hosted Looker instances must prioritize upgrading to the patched versions listed by Google (24.12.103+, 24.18.195+, 25.0.72+, 25.6.60+, 25.8.42+, or 25.10.22+). Beyond patching, organizations should implement strict role-based access control (RBAC) to limit the number of users with the Looker Developer role, reducing the attack surface. Regular audits of developer activities and Git operations within Looker should be conducted to detect anomalous behavior indicative of exploitation attempts. Network segmentation and monitoring of Looker server communications can help detect and contain potential breaches. Employing application-layer firewalls or endpoint detection and response (EDR) solutions on Looker servers can provide additional layers of defense. Finally, organizations should ensure that incident response plans include scenarios involving Looker compromise to enable rapid containment and recovery.

Description

An attacker with a Looker Developer role could manipulate a LookML project to exploit a race condition during Git directory deletion, leading to arbitrary command execution on the Looker instance. Looker-hosted and Self-hosted were found to be vulnerable. This issue has already been mitigated for Looker-hosted instances. No user action is required for these. Self-hosted instances must be upgraded as soon as possible. This vulnerability has been patched in all supported versions of Self-hosted. The versions below have all been updated to protect from this vulnerability. You can download these versions at the Looker download page https://download.looker.com/ : * 24.12.103+ * 24.18.195+ * 25.0.72+ * 25.6.60+ * 25.8.42+ * 25.10.22+

References

Community reviews

Loading reviews…