Skip to main content
CVE-2025-12705VulnerabilityPublished Updated

CVE-2025-12705: Reviews Widgets for Google, Yelp & TripAdvisor (WordPress plugin) · Cross-site Scripting

Affects Reviews Widgets for Google, Yelp & TripAdvisor (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 7.2 High · fixed in 2.5 : patch Reviews Widgets for Google, Yelp & TripAdvisor (WordPress plugin) soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Affected software

ProductAffectedFixed in
widgetpack Reviews Widgets for Google, Yelp & TripAdvisorAffected
  • =0
Fixed in–

AI-suggested

A partial patch was introduced in version 2.5 of the plugin; however, no complete fix is confirmed. Until a full fix is released, consider disabling or removing the vulnerable plugin to prevent exploitation.

Description

The Social Reviews & Recommendations plugin for WordPress is vulnerable to Stored Cross-Site Scripting via several parameters in the 'trim_text' function in all versions up to, and including, 2.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 2.5.

References

Community reviews

Loading reviews…