CVE-2025-12742: Google Cloud Looker · OS Command Injection
Affects Google Cloud LookerSource CVE Database V5
Not known to be exploited · CVSS 7.5 High.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/U:RedExploitation evidence
Disclosed: evidence found.
CVE published 25 Nov 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Google Cloud Looker | Affected
| Fixed in– |
AI-suggested
European organizations using self-hosted Looker instances must urgently upgrade to one of the patched versions provided by Google Cloud (24.12.108+, 24.18.200+, 25.0.78+, 25.6.65+, 25.8.47+, 25.12.10+, 25.14+). Beyond patching, organizations should audit and restrict Developer role assignments to trusted personnel only, implementing strict role-based access controls. Monitoring and logging of Looker user activities, especially those with elevated privileges, should be enhanced to detect anomalous command executions or parameter manipulations. Network segmentation can limit access to Looker servers, reducing exposure. Additionally, organizations should review Teradata driver configurations and sanitize inputs where possible. Regular vulnerability scanning and penetration testing focused on analytics platforms can help identify residual risks. Finally, integrating Looker security posture into broader cloud security frameworks and incident response plans will improve resilience against exploitation.
Description
A Looker user with a Developer role could cause Looker to execute a malicious command, due to insecure processing of Teradata driver parameters. Looker-hosted and Self-hosted were found to be vulnerable. This issue has already been mitigated for Looker-hosted instances. No user action is required for these. Self-hosted instances must be upgraded as soon as possible. This vulnerability has been patched in all supported versions of Self-hosted. The versions below have all been updated to protect from this vulnerability. You can download these versions at the Looker download page https://download.looker.com/ : * 24.12.108+ * 24.18.200+ * 25.0.78+ * 25.6.65+ * 25.8.47+ * 25.12.10+ * 25.14+