Skip to main content
CVE-2025-12763VulnerabilityPublished Updated

CVE-2025-12763: pgAdmin 4 · OS Command Injection

Affects pgAdmin 4Source CVE Database V5

0

Not known to be exploited · CVSS 6.8 Medium : upgrade to 9.9 when convenient.

Data as of 26 Oct 2026, 07:57 UTC

CVSS 3.1 base score
6.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.9% chance of exploitation in 30 days – higher than 59% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.9
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade pgadmin-org/pgadmin4 to 9.9.

Affected software

ProductAffectedFixed in
GitHubpgadmin-org/pgadmin4pkg:github/pgadmin-org/pgadmin4Other threatsAffected
  • <9.9
Fixed in
  • 9.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, organizations should implement several specific mitigations: 1) Restrict access to pgAdmin 4 instances to trusted users only and enforce strong authentication mechanisms, including multi-factor authentication. 2) Limit user permissions within pgAdmin to the minimum necessary to reduce the risk of malicious input. 3) Avoid running pgAdmin 4 on Windows systems if possible; consider using Linux-based deployments where this vulnerability does not apply. 4) Monitor logs for unusual backup or restore operations that may indicate exploitation attempts. 5) Employ application whitelisting and endpoint protection solutions to detect and block unauthorized command execution. 6) Educate users about the risks of providing untrusted input during backup and restore processes. 8) Consider network segmentation to isolate database management tools from less trusted network zones. These targeted actions go beyond generic advice by focusing on the specific attack vector and environment.

Description

pgAdmin 4 versions up to 9.9 are affected by a command injection vulnerability on Windows systems. This issue is caused by the use of shell=True during backup and restore operations, enabling attackers to execute arbitrary system commands by providing specially crafted file path input.

References

Community reviews

Loading reviews…