Skip to main content
VulnerabilityPublished Updated

CVE-2025-12819: PgBouncer · Untrusted Search Path

Affects PgBouncerSource CVE Database V5

0

Not known to be exploited · CVSS 7.5 High : upgrade to 1.25.1 soon.

Data as of 26 Oct 2026, 13:47 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 30% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.25.1
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Debian debian/pgbouncer package to 1.25.1.

Affected software

ProductAffectedFixed in
Debiandebian/pgbouncerpkg:deb/debian/pgbouncerOther threatsAffected
  • <1.25.1
Fixed in
  • 1.25.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

  1. Upgrade PgBouncer to version 1.25.1 or later immediately to apply the fix for the untrusted search path vulnerability.
  2. Restrict network access to PgBouncer instances by implementing firewall rules and network segmentation, limiting connections to trusted hosts only.
  3. Monitor authentication logs and database activity for unusual or unauthorized SQL commands that could indicate exploitation attempts.
  4. Employ application-layer firewalls or database activity monitoring tools to detect and block malicious queries targeting the search_path parameter.
  5. Review and harden PostgreSQL and PgBouncer configuration settings, minimizing privileges and disabling unnecessary features.
  6. Conduct regular security audits and vulnerability assessments focused on database infrastructure.
  7. Educate database administrators and security teams about this vulnerability and the importance of timely patching.
  8. Implement multi-factor authentication and strong access controls for database management interfaces to reduce risk of privilege escalation.

Description

Untrusted search path in auth_query connection handler in PgBouncer before 1.25.1 allows an unauthenticated attacker to execute arbitrary SQL during authentication via a malicious search_path parameter in the StartupMessage.

References

Community reviews

Loading reviews…