CVE-2025-13192: Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers (WordPress plugin) · SQL Injection
Affects Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 8.2 High · fixed in 2.2.1 : patch Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers (WordPress plugin) soon.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.2.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 4 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| roxnorPopup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers | Affected
| Fixed in– |
AI-suggested
Users should upgrade the roxnor Popup builder plugin to version 2.2.3 or later to ensure full remediation of this vulnerability for all user levels. Versions 2.2.1 and 2.2.2 provide partial fixes for unauthenticated users but do not fully address administrator-level exploitation. No other mitigations are indicated by the vendor advisory. Patch status is confirmed by the version history described in the vulnerability details.
Description
The Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers plugin for WordPress is vulnerable to generic SQL Injection via the multiple REST API endpoints in all versions up to, and including, 2.2.0 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. Vulnerability was patched in version 2.2.1 for unauthenticated users, and fully patched in version 2.2.3 for Administrator+ level users.
References
- wordfence.com/threat-intel/vulnerabilities/id/9db1dfde-0cba-41b2-ab7a-a1640e5fd96b?source=cve (opens in a new tab)
- plugins.trac.wordpress.org/browser/popup-builder-block/tags/2.1.5/includes/Routes/Popup.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/popup-builder-block/tags/2.1.5/includes/Routes/Popup.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/popup-builder-block/tags/2.1.5/includes/Helpers/DataBase.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/popup-builder-block/tags/2.1.5/includes/Helpers/DataBase.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/popup-builder-block/tags/2.1.5/includes/Routes/Subscribers.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/popup-builder-block/tags/2.1.5/includes/Routes/Subscribers.php (opens in a new tab)