Skip to main content
CVE-2025-13744VulnerabilityPublished

CVE-2025-13744: GitHub Enterprise Server · XSS or 'Cross-site Scripting'

Affects GitHub Enterprise ServerSource CVE Database V5

0

Not known to be exploited · CVSS 8.4 High · fixed in 3.19.1 : patch GitHub Enterprise Server soon.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 4.0 base score
8.4High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.19.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:L/VA:N/SC:H/SI:H/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Affected software

ProductAffectedFixed in
GitHubEnterprise ServerAffected
  • >=3.14.0 <3.14.20
  • >=3.15.0 <3.15.15
  • >=3.16.0 <3.16.11
  • >=3.17.0 <3.17.8
  • >=3.18.0 <3.18.2
  • >=3.19 <3.19.1
Fixed in–

AI-suggested

1. Immediately upgrade GitHub Enterprise Server to one of the patched versions: 3.19.1, 3.18.2, 3.17.8, 3.16.11, 3.15.15, or 3.14.20 or later. 2. Review and restrict permissions to create or modify milestone, issue, and pull request names to trusted users only, minimizing the risk of malicious input. 3. Implement strict input validation and sanitization policies on user-generated content within GitHub Enterprise Server, if customization is possible. 4. Monitor logs and audit trails for unusual activity related to entity name changes or search/filter usage that could indicate exploitation attempts. 5. Educate users about the risks of clicking on suspicious links or content within the GitHub environment to reduce the risk of social engineering. 6. Employ Content Security Policy (CSP) headers and other browser security mechanisms to limit the impact of potential XSS payloads. 7. Regularly review and update security configurations and conduct penetration testing focused on web application vulnerabilities in the development infrastructure.

Description

An Improper Neutralization of Input During Web Page Generation vulnerability was identified in GitHub Enterprise Server that allowed attacker controlled HTML to be rendered by the Filter component (search) across GitHub that could be used to exfiltrate sensitive information. An attacker would require permissions to create or modify the names of milestones, issues, pull requests, or similar entities that are rendered in the vulnerable filter/search components. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.20 and was fixed in versions 3.19.1, and 3.18.2, 3.17.8, 3.16.11, 3.15.15, and 3.14.20. This vulnerability was reported via the GitHub Bug Bounty program.

References

Community reviews

Loading reviews…