CVE-2025-13979: Drupal Mini site · Privilege Defined With Unsafe Actions
Affects Drupal Mini siteSource CVE Database V5
Not known to be exploited · CVSS 5.4 Medium : upgrade to 3.0.2 when convenient.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.0.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Drupal Mini site to 3.0.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| DrupalMini site | Affected
| Fixed in
|
AI-suggested
European organizations should immediately inventory their Drupal Mini site installations to identify affected versions prior to 3.0.2. Until an official patch or upgrade is applied, restrict privileges associated with the vulnerable actions to the minimum necessary users and roles, applying the principle of least privilege. Implement Web Application Firewalls (WAF) with rules to detect and block common XSS payloads targeting Drupal endpoints. Conduct thorough code reviews and input validation enhancements to sanitize user inputs and outputs within the Mini site module. Monitor logs for unusual activity indicative of stored XSS exploitation attempts, such as unexpected script injections or anomalous user behavior. Educate administrators and developers about the risks of unsafe privilege assignments and encourage prompt application of security updates once available. Additionally, consider deploying Content Security Policy (CSP) headers to mitigate the impact of injected scripts. Regularly back up Drupal site data and configurations to enable rapid recovery if an attack occurs. Finally, coordinate with Drupal community channels to stay informed about patches and advisories related to this vulnerability.
Description
CVE-2025-13979 is a medium severity vulnerability in the Drupal Mini site module versions before 3.0.2. It involves a privilege defined with unsafe actions (CWE-267) that allows an authenticated user with certain privileges to perform stored Cross-Site Scripting (XSS) attacks without requiring user interaction. The vulnerability impacts confidentiality and integrity but does not affect availability. Exploitation requires network access and low complexity with privileges, but no user interaction. There are no known exploits in the wild yet, and no patches have been linked. European organizations using affected Drupal Mini site versions should prioritize updating to mitigate risks, especially those with web-facing Drupal installations. Countries with higher Drupal adoption and critical infrastructure relying on Drupal are more likely to be impacted.