Skip to main content
CVE-2025-13980VulnerabilityPublished

CVE-2025-13980: Drupal CKEditor 5 Premium Features · Authentication Bypass Using an Alternate Path or Channel

Affects Drupal CKEditor 5 Premium FeaturesSource CVE Database V5

0

Not known to be exploited · CVSS 5.3 Medium · fixed in 1.6.4 : update Drupal CKEditor 5 Premium Features when convenient.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.6.4, 1.5.1, 1.4.3 +2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
DrupalCKEditor 5 Premium FeaturesAffected
  • <1.2.10
  • >=1.3.0 <1.3.6
  • >=1.4.0 <1.4.3
  • >=1.5.0 <1.5.1
  • >=1.6.0 <1.6.4
Fixed in
  • 1.6.4
  • 1.5.1
  • 1.4.3
  • 1.3.6
  • 1.2.10
Packagistdrupal/ckeditor5-premium-featurespkg:composer/drupal/ckeditor5-premium-featuresOther threatsAffected
  • =0.0.0
  • =1.3.0
  • =1.4.0
  • =1.5.0
  • =1.6.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

1. Immediately upgrade CKEditor 5 Premium Features to the latest patched versions beyond 1.2.10, 1.3.6, 1.4.3, 1.5.1, or 1.6.4 depending on the installed version. 2. Restrict access to CKEditor 5 Premium Features to trusted users and networks, employing network segmentation and access control lists where feasible. 3. Implement web application firewalls (WAF) with custom rules to detect and block suspicious requests targeting CKEditor endpoints. 4. Monitor Drupal logs and web server access logs for unusual or unauthorized access attempts to CKEditor features. 5. Conduct regular vulnerability scans and penetration tests focusing on Drupal CMS and its components. 6. Educate site administrators about the risks of using outdated CKEditor versions and enforce patch management policies. 7. Consider disabling premium features if not essential until patches are applied. 8. Employ multi-factor authentication (MFA) for administrative access to Drupal sites to reduce risk from chained attacks.

Description

CVE-2025-13980 is an authentication bypass vulnerability in Drupal's CKEditor 5 Premium Features that allows attackers to bypass authentication without any user interaction or privileges. It affects multiple versions prior to fixed releases, enabling unauthorized access through alternate paths or channels. The vulnerability has a medium severity with a CVSS score of 5.3, impacting confidentiality but not integrity or availability. No known exploits are currently reported in the wild. European organizations using affected Drupal CKEditor 5 Premium Features versions could face unauthorized access risks, particularly those with public-facing Drupal sites. Mitigation requires prompt updating to patched versions beyond 1.2.10, 1.3.

References

Community reviews

Loading reviews…