CVE-2025-13984: Drupal Next.js · Permissive Cross-domain Security Policy with Untrusted Domains
Affects Drupal Next.jsSource CVE Database V5
Not known to be exploited · CVSS 6.1 Medium : upgrade to 2.0.1 or 1.6.4 when convenient.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.0.1, 1.6.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade Drupal Next.js to 2.0.1 or 1.6.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| DrupalNext.js | Affected
| Fixed in
|
npmnextpkg:npm/nextOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should immediately identify any Drupal installations using affected Next.js versions (prior to 1.6.4 and 2.0.1). The primary mitigation is to upgrade Next.js to version 1.6.4 or later, or 2.0.1 or later, where the vulnerability is resolved. If immediate upgrading is not feasible, organizations should review and tighten cross-domain security policies, including Content Security Policy (CSP) headers, to restrict allowed domains explicitly and avoid wildcard or overly permissive settings. Implementing strict input validation and output encoding can reduce the risk of XSS exploitation. Additionally, employing web application firewalls (WAFs) with rules targeting XSS patterns can provide temporary protection. Regular security audits and penetration testing focusing on cross-domain policies and XSS vectors are recommended. User awareness training to recognize phishing and suspicious links can help mitigate user interaction risks. Monitoring for unusual script execution or anomalous web traffic may help detect exploitation attempts early.
Description
CVE-2025-13984 is a medium severity vulnerability in Drupal's Next.js integration involving a permissive cross-domain security policy that allows untrusted domains. This misconfiguration enables Cross-Site Scripting (XSS) attacks by permitting malicious domains to execute scripts in the context of trusted sites. The vulnerability affects Next.js versions from 0.0.0 before 1.6.4 and from 2.0.