Skip to main content
VulnerabilityPublished Updated

CVE-2025-14280: PixelYourSite (WordPress plugin) · Information Exposure

Affects PixelYourSite (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 5.3 Medium · fixed in 11.1.5.1 : update PixelYourSite (WordPress plugin) when convenient.

Data as of 26 Oct 2026, 12:55 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 11.1.5.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
pixelyoursite PixelYourSite – Your smart PIXEL (TAG) & API ManagerAffected
  • =0
Fixed in–

AI-suggested

Users should upgrade to PixelYourSite version 11.1.5.1 or later, where the vulnerability is fully patched. If upgrading immediately is not possible, ensure that the 'Meta API logs' setting remains disabled to prevent exposure. Patch status is confirmed fixed in version 11.1.5.1.

Description

The PixelYourSite plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 11.1.5 through publicly exposed log files. This makes it possible for unauthenticated attackers to view potentially sensitive information contained in the exposed log files, when the "Meta API logs" setting is enabled (disabled by default). The vulnerability was partially patched in version 11.1.5 and fully patched in version 11.1.5.1.

References

Community reviews

Loading reviews…