CVE-2025-14437: Hummingbird Performance (WordPress plugin) · Sensitive Data in Logs
Affects Hummingbird Performance (WordPress plugin)Source CVE Database V5
Not known to be exploited · public detection template (Nuclei) · CVSS 7.5 High · patch available : patch Hummingbird Performance (WordPress plugin) soon.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 1.8% chance of exploitation in 30 days – higher than 78% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 18 Dec 2025
Detectable: evidence found.
nuclei template: WordPress Hummingbird <= 3.18.0 - Sensitive Information Exposure via Log File
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| wpmudev Hummingbird Performance – Cache & Page Speed Optimization for Core Web Vitals | Critical CSS | Minify CSS | Defer CSS Javascript | CDN | Affected
| Fixed in– |
AI-suggested
A patch is available for this vulnerability. Users of the Hummingbird Performance plugin should update to the latest version beyond 3.18.0 to remediate the issue. Since this is not a cloud service, remediation depends on applying the vendor's patch. No additional mitigation steps are specified in the advisory.
Description
The Hummingbird Performance plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.18.0 via the 'request' function. This makes it possible for unauthenticated attackers to extract sensitive data including Cloudflare API credentials.