Skip to main content
CVE-2025-14507VulnerabilityPublished Updated

CVE-2025-14507: EventPrime (WordPress plugin) · Information Exposure

Affects EventPrime (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 5.3 Medium · fixed in 4.2.7.0 : update EventPrime (WordPress plugin) when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.2.7.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Affected software

ProductAffectedFixed in
metagaussEventPrime – Events Calendar, Bookings and TicketsAffected
  • <=4.2.7.0
Fixed in–

AI-suggested

Since the vulnerability is only partially patched in version 4.2.7.0 and no official full patch or advisory is provided, users should upgrade to version 4.2.7.0 to benefit from the partial fix. Additionally, administrators should consider disabling the REST API if it is not required to reduce exposure. Patch status is not yet fully confirmed—check the vendor advisory for current remediation guidance.

Description

The EventPrime - Events Calendar, Bookings and Tickets plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 4.2.7.0 via the REST API. This makes it possible for unauthenticated attackers to extract sensitive booking data including user names, email addresses, ticket details, payment information, and order keys when the API is enabled by an administrator. The vulnerability was partially patched in version 4.2.7.0.

References

Community reviews

Loading reviews…