CVE-2025-14546: fastapi-sso · Cross-site Request Forgery (CSRF)
Affects fastapi-ssoSource CVE Database V5
Not known to be exploited · CVSS 6.9 Medium : upgrade to 0.19.0 when convenient.
Data as of 26 Oct 2026, 07:57 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.19.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 19 Dec 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade fastapi-sso to 0.19.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
PyPIfastapi-ssopkg:pypi/fastapi-ssoOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should immediately upgrade fastapi-sso to version 0.19.0 or later, where this vulnerability is fixed by properly persisting and validating the OAuth state parameter against the user's session. If upgrading is not immediately feasible, organizations should implement additional CSRF protections around the OAuth callback endpoint, such as verifying the state parameter against a server-side stored value or employing anti-CSRF tokens at the application level. Monitoring and logging OAuth authentication flows for anomalies in state parameters can help detect exploitation attempts. User education to recognize phishing attempts that might lead to malicious callback URLs is also recommended. Additionally, organizations should review their OAuth implementation to ensure adherence to best practices for state parameter handling and session management. Conducting penetration testing focused on OAuth flows can help identify residual weaknesses. Finally, maintain awareness of any emerging exploits or patches related to this CVE.
Description
Versions of the package fastapi-sso before 0.19.0 are vulnerable to Cross-site Request Forgery (CSRF) due to the improper validation of the OAuth state parameter during the authentication callback. While the get_login_url method allows for state generation, it does not persist the state or bind it to the user's session. Consequently, the verify_and_process method accepts the state received in the query parameters without verifying it against a trusted local value. This allows a remote attacker to trick a victim into visiting a malicious callback URL, which can result in the attacker's account being linked to the victim's internal account.