CVE-2025-14561: WSO2 API Manager · Improper Access Control
Affects WSO2 API ManagerSource CVE Database V5
Not known to be exploited · CVSS 9.0 Critical · fixed in 4.6.0.6 : patch WSO2 API Manager as a priority.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.6.0.6, 4.5.0.41, 4.4.0.57 +12
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:LExploitation evidence
Disclosed: evidence found.
CVE published 6 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| WSO2WSO2 API Manager | Affected
| Fixed in
|
| WSO2WSO2 API Manager | Affected
| Fixed in
|
| WSO2WSO2 API Manager | Affected
| Fixed in
|
| WSO2WSO2 API Manager | Affected
| Fixed in
|
| WSO2WSO2 API Manager | Affected
| Fixed in
|
| WSO2WSO2 API Manager | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, restrict privileged user access to trusted personnel only and monitor API management activities closely to detect any unauthorized cross-tenant operations.
Description
CVE-2025-14561 is a critical improper access control vulnerability in WSO2 API Manager affecting multi-tenant deployments. The Publisher REST APIs do not properly enforce tenant isolation, allowing a privileged user in one tenant to perform publisher operations such as exposing or modifying API metadata in other tenants. This issue impacts versions 4.1.0 through 4.6.0. The vulnerability has a CVSS score of 9.0, indicating high impact on confidentiality, integrity, and availability.