Skip to main content
CVE-2025-1461VulnerabilityPublished Updated

CVE-2025-1461: Vuetify · XSS or 'Cross-site Scripting'

Affects VuetifySource CVE Database V5

0

Not known to be exploited · CVSS 5.6 Medium : upgrade to 3.0.0 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
5.6Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.0.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade Vuetify to 3.0.0.

Affected software

ProductAffectedFixed in
npmvuetifypkg:npm/vuetifyOther threatsAffected
  • >=2.0.0 <3.0.0
Fixed in
  • 3.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should undertake a thorough inventory of web applications using Vuetify 2.x and specifically the 'VCalendar' component. Immediate mitigation steps include: 1) Upgrading to Vuetify 3.x or later, which is actively maintained and not affected by this vulnerability. If upgrade is not feasible, consider refactoring to remove or replace the vulnerable component. 2) Implement strict input validation and output encoding on any user-controllable inputs that influence the 'eventMoreText' property to prevent injection of malicious HTML. 3) Employ Content Security Policy (CSP) headers to restrict script execution sources and reduce the impact of potential XSS attacks. 4) Use web application firewalls (WAFs) with rules targeting XSS patterns to detect and block exploit attempts. 5) Conduct security testing, including automated scanning and manual code review, focusing on UI components rendering dynamic content. 6) Educate developers on secure coding practices related to UI frameworks and translation mechanisms. These targeted actions go beyond generic advice by addressing the specific nature of the vulnerability and the challenges posed by the EOL status of the affected Vuetify versions.

Description

Improper neutralization of the value of the 'eventMoreText' property of the 'VCalendar' component in Vuetify allows unsanitized HTML to be inserted into the page. This can lead to a  Cross-Site Scripting (XSS) https://owasp.org/www-community/attacks/xss  attack. The vulnerability occurs because the default Vuetify translator will return the translation key as the translation, if it can't find an actual translation. This issue affects Vuetify versions greater than or equal to 2.0.0 and less than 3.0.0. Note: Version 2.x of Vuetify is End-of-Life and will not receive any updates to address this issue. For more information see here https://v2.vuetifyjs.com/en/about/eol/ .

References

Community reviews

Loading reviews…