Skip to main content
CVE-2025-14691VulnerabilityPublished

CVE-2025-14691: Mayan EDMS · Cross Site Scripting

Affects Mayan EDMSSource CVE Database V5

0

Not known to be exploited · CVSS 5.3 Medium.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Affected software

ProductAffectedFixed in
GitHubionutluca888/Mayan-EDMSpkg:github/ionutluca888/Mayan-EDMSOther threatsAffected
  • =4.10.0
  • =4.10.1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately upgrade all instances of Mayan EDMS to version 4.10.2 or later to remediate this vulnerability. For environments where immediate upgrade is not feasible, applying vendor-provided backported patches for older versions as soon as they become available is essential. Additionally, organizations should implement strict input validation and output encoding on all user-supplied data within the /authentication/ module to prevent script injection. Deploying Web Application Firewalls (WAFs) with rules targeting XSS attack patterns can provide temporary protection. User awareness training should emphasize caution with unsolicited links and emails to reduce the risk of successful social engineering. Monitoring web server logs for suspicious requests targeting the /authentication/ path can help detect attempted exploitation. Finally, organizations should review session management policies to ensure secure cookie attributes (HttpOnly, Secure, SameSite) are enforced to mitigate session hijacking risks.

Description

A vulnerability was detected in Mayan EDMS up to 4.10.1. The affected element is an unknown function of the file /authentication/. The manipulation results in cross site scripting. The attack may be performed from remote. The exploit is now public and may be used. Upgrading to version 4.10.2 is sufficient to fix this issue. You should upgrade the affected component. The vendor confirms that this is "[f]ixed in version 4.10.2". Furthermore, that "[b]ackports for older versions in process and will be out as soon as their respective CI pipelines complete."

References

Community reviews

Loading reviews…