CVE-2025-14803: NEX-Forms (WordPress plugin) · Cross-Site Scripting (XSS)
Affects NEX-Forms (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 6.8 Medium : upgrade to 9.1.8 when convenient.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.1.8
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 9 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade NEX-Forms (WordPress plugin) to 9.1.8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| NEX-Forms | Affected
| Fixed in
|
AI-suggested
1. Upgrade NEX-Forms plugin to version 9.1.8 or later as soon as it becomes available to ensure the vulnerability is patched. 2. Restrict subscriber-level user permissions to the minimum necessary, avoiding granting access to form settings or administrative functions. 3. Implement Web Application Firewalls (WAF) with rules to detect and block XSS payloads targeting form inputs and plugin settings. 4. Conduct regular security audits and code reviews of WordPress plugins and configurations to identify and remediate insecure settings. 5. Educate users with subscriber roles about phishing and social engineering risks to reduce the chance of account compromise. 6. Monitor logs for unusual activity related to form submissions or settings changes that could indicate exploitation attempts. 7. Consider isolating critical WordPress instances or using security plugins that enforce content sanitization and output encoding. 8. Maintain up-to-date backups to enable rapid recovery in case of compromise.
Description
CVE-2025-14803 is a stored Cross-Site Scripting (XSS) vulnerability in the NEX-Forms WordPress plugin versions before 9.1.8. The flaw arises because certain plugin settings are not properly sanitized or escaped, allowing authenticated subscribers to inject malicious scripts. Exploitation requires subscriber-level privileges and user interaction, but can lead to full compromise of confidentiality, integrity, and availability of affected sites. The vulnerability has a CVSS score of 6.8, indicating medium severity. No known exploits are currently reported in the wild. European organizations using NEX-Forms on WordPress should prioritize patching or mitigating this issue to prevent potential account takeover, data theft, or site defacement. Countries with high WordPress adoption and significant use of NEX-Forms, such as Germany, the UK, and France, are most likely to be impacted.