CVE-2025-14804: Frontend File Manager Plugin · External Control of File Name or Path
Affects Frontend File Manager PluginSource CVE Database V5
Not known to be exploited · CVSS 7.7 High : upgrade to 23.5 soon.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 23.5
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 7 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Frontend File Manager Plugin to 23.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Frontend File Manager Plugin | Affected
| Fixed in
|
AI-suggested
- Immediately update the Frontend File Manager plugin to version 23.5 or later, where the vulnerability is patched.
- Restrict plugin access strictly to trusted users with elevated privileges; avoid granting subscriber-level users access to file management features.
- Implement web application firewalls (WAF) with rules to detect and block suspicious file path manipulation attempts targeting the plugin endpoints.
- Regularly audit user roles and permissions within WordPress to ensure minimal necessary privileges are assigned.
- Monitor server logs for unusual file deletion activities or unauthorized access attempts related to the plugin.
- Maintain regular backups of website files and databases to enable rapid recovery in case of file deletion or tampering.
- Consider isolating file management functionality to separate environments or using alternative plugins with stronger security track records.
- Educate site administrators about the risks of granting file management capabilities to low-privilege users.
Description
CVE-2025-14804 is a high-severity vulnerability in the Frontend File Manager WordPress plugin prior to version 23.5. It allows any authenticated user, including low-privilege roles like subscribers, to delete arbitrary files on the server due to improper validation of a path parameter and file ownership. The vulnerability does not require user interaction and can be exploited remotely over the network. While it does not impact confidentiality or availability, it severely impacts integrity by enabling unauthorized file deletion. No known exploits are currently reported in the wild. European organizations using this plugin on WordPress sites are at risk, especially those with subscriber-level users. Mitigation requires immediate updating to version 23.5 or later and restricting plugin access to trusted users only. Countries with high WordPress usage and significant e-commerce or media sectors, such as Germany, France, and the UK, are most likely affected.