CVE-2025-15030: User Profile Builder (WordPress plugin) · Improper Privilege Management
Affects User Profile Builder (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 9.8 Critical : upgrade to 3.15.2 as a priority.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.15.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 2 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade User Profile Builder (WordPress plugin) to 3.15.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| User Profile Builder | Affected
| Fixed in
|
AI-suggested
1. Immediately update the User Profile Builder plugin to version 3.15.2 or later once available to apply the official patch. 2. If a patch is not yet available, temporarily disable the password reset functionality in the plugin or restrict access to it via web application firewall (WAF) rules to block unauthenticated password reset requests. 3. Implement monitoring and alerting for unusual password reset attempts or multiple reset requests targeting administrative usernames. 4. Enforce strong, unique passwords and consider multi-factor authentication (MFA) for all administrative accounts to reduce risk of account compromise. 5. Review and harden WordPress user roles and permissions to minimize impact if an account is compromised. 6. Conduct regular security audits and vulnerability scans on WordPress sites to detect outdated plugins and configuration weaknesses. 7. Educate site administrators on the risks and signs of exploitation related to this vulnerability. 8. Consider isolating critical WordPress instances behind VPNs or IP whitelisting to limit exposure.
Description
CVE-2025-15030 is a critical vulnerability in the User Profile Builder WordPress plugin versions before 3.15.2. It allows unauthenticated attackers to reset the password of any user, including administrators, by simply knowing their username. This flaw stems from improper privilege management in the password reset process, enabling full account takeover without user interaction or authentication. The vulnerability has a CVSS score of 9.8, reflecting its high impact on confidentiality, integrity, and availability. Although no known exploits are currently reported in the wild, the ease of exploitation and severity make it a significant threat. European organizations using this plugin on WordPress sites are at risk, especially those with high-value administrative accounts. Immediate patching or mitigation is essential to prevent unauthorized access and potential data breaches.