Skip to main content
VulnerabilityPublished

CVE-2025-15315: Tanium Module Server · Argument Injection

Affects Tanium Module ServerSource CVE Database V5

0

Not known to be exploited · CVSS 6.7 Medium · fixed in 7.6.4.2114 : update Tanium Module Server when convenient.

Data as of 26 Oct 2026, 11:42 UTC

CVSS 3.1 base score
6.7Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.6.4.2114, 7.6.2.1293, 7.5.6.1161 +1
CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Tanium Module Server to 7.6.4.2114, 7.6.2.1293, 7.5.6.1161 or 7.4.6.1151.

Affected software

ProductAffectedFixed in
TaniumTanium Module ServerAffected
  • >=7.6.4.0 <7.6.4.2114
Fixed in
  • 7.6.4.2114
TaniumTanium Module ServerAffected
  • >=7.6.2.0 <7.6.2.1293
Fixed in
  • 7.6.2.1293
TaniumTanium Module ServerAffected
  • >=7.5.6.0 <7.5.6.1161
Fixed in
  • 7.5.6.1161
TaniumTanium Module ServerAffected
  • >=7.4.6.0 <7.4.6.1151
Fixed in
  • 7.4.6.1151

CPE configurations (4)

  • cpe:2.3:a:tanium:moduleserver:7.5.6.1160:*:*:*:*:*:*:*
  • cpe:2.3:a:tanium:moduleserver:7.4.6.1150:*:*:*:*:*:*:*
  • cpe:2.3:a:tanium:moduleserver:7.6.2.1292:*:*:*:*:*:*:*
  • cpe:2.3:a:tanium:moduleserver:7.6.4.2113:*:*:*:*:*:*:*

AI-suggested

European organizations should implement the following specific mitigation steps: 1) Immediately identify and inventory all Tanium Module Server instances running affected versions (7.4.6.0, 7.5.6.0, 7.6.2.0, 7.6.4.0). 2) Apply the official patches provided by Tanium as soon as possible to remediate the vulnerability. 3) Restrict local access to Tanium Module Server hosts to trusted administrators only, employing strict access controls and monitoring. 4) Implement robust endpoint detection and response (EDR) solutions to detect anomalous local privilege escalation attempts. 5) Conduct regular audits of user privileges and remove unnecessary elevated rights to minimize the risk of privilege abuse. 6) Employ application whitelisting and command-line argument monitoring to detect and block suspicious command injections. 7) Maintain comprehensive logging and alerting on Tanium Module Server activities to enable rapid detection of exploitation attempts. 8) Educate system administrators on the risks of local privilege escalation and the importance of patch management. These measures, combined with timely patching, will significantly reduce the risk posed by this vulnerability.

Description

CVE-2025-15315 is a local privilege escalation vulnerability in the Tanium Module Server caused by improper neutralization of argument delimiters leading to argument injection. It affects specific versions of Tanium Module Server (7.4.6.0, 7.5.6.0, 7.6.2.

References

Community reviews

Loading reviews…