Skip to main content
VulnerabilityPublished

CVE-2025-15363: Get Use APIs (WordPress plugin) · Cross-Site Scripting (XSS)

Affects Get Use APIs (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.9 Medium : upgrade to 2.0.10 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.0.10
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Get Use APIs (WordPress plugin) to 2.0.10.

Affected software

ProductAffectedFixed in
Get Use APIsAffected
  • <2.0.10
Fixed in
  • 2.0.10

AI-suggested

To mitigate CVE-2025-15363 effectively, organizations should take the following specific actions: 1) Immediately audit WordPress sites for the presence of the Get Use APIs plugin and identify versions prior to 2.0.10. 2) Apply updates to version 2.0.10 or later as soon as the patch becomes available, or contact the plugin vendor for interim fixes or workarounds. 3) Restrict contributor role permissions by limiting the number of users assigned this role and reviewing their activities regularly. 4) Implement strict input validation and output encoding on any JSON import functionality, ensuring that imported data cannot execute scripts. 5) Employ Web Application Firewalls (WAFs) with custom rules to detect and block suspicious JSON payloads or script injections targeting the plugin's endpoints. 6) Monitor logs for unusual contributor activity or unexpected JSON imports. 7) Educate content contributors about security best practices and the risks of importing untrusted data. 8) Consider temporarily disabling the JSON import feature if it is not essential, reducing the attack surface. 9) Regularly back up website data and configurations to enable quick recovery in case of compromise. These targeted measures go beyond generic advice by focusing on the specific attack vector and user roles involved in this vulnerability.

Description

The Get Use APIs WordPress plugin before 2.0.10 executes imported JSON, which could allow users with a role as low as contributor to perform Cross-Site Scripting attacks under certain server configurations.

References

Community reviews

Loading reviews…