Skip to main content
CVE-2025-15396VulnerabilityPublished

CVE-2025-15396: Library Viewer (WordPress plugin) · Cross-Site Scripting (XSS)

Affects Library Viewer (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 7.1 High : upgrade to 3.2.0 soon.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.2.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade Library Viewer (WordPress plugin) to 3.2.0.

Affected software

ProductAffectedFixed in
Library ViewerAffected
  • <3.2.0
Fixed in
  • 3.2.0

AI-suggested

1. Update the Library Viewer plugin to version 3.2.0 or later as soon as it becomes available, as this will include proper input sanitization and escaping to prevent XSS. 2. If you cannot patch yet, implement a Web Application Firewall (WAF) with rules specifically designed to detect and block reflected XSS payloads targeting the plugin’s parameters. 3. Restrict administrative access to the WordPress backend and the plugin interface by IP whitelisting or VPN access to reduce exposure to malicious links. 4. Educate administrators and high-privilege users about the risks of clicking on unsolicited or suspicious links, particularly those that may contain URL parameters. 5. Employ Content Security Policy (CSP) headers to limit the execution of unauthorized scripts in browsers, mitigating the impact of potential XSS payloads. 6. Regularly audit and monitor web server logs and WordPress activity logs for unusual access patterns or attempts to exploit XSS vectors. 7. Consider disabling or limiting the use of the Library Viewer plugin if it is not essential, reducing the attack surface. 8. Engage in proactive vulnerability scanning and penetration testing focused on web application security to identify similar issues early.

Description

CVE-2025-15396 is a high-severity reflected Cross-Site Scripting (XSS) vulnerability in the Library Viewer WordPress plugin versions before 3.2.0. The vulnerability arises because the plugin fails to properly sanitize and escape certain parameters before reflecting them in the page output. This flaw allows attackers to craft malicious URLs that, when visited by high-privilege users such as administrators, can execute arbitrary scripts in their browsers. Exploitation requires user interaction but no prior authentication, and it can impact confidentiality, integrity, and availability by stealing session tokens, performing actions on behalf of admins, or defacing content. Although no known exploits are currently reported in the wild, the vulnerability’s CVSS score of 7.1 indicates a significant risk. European organizations using the Library Viewer plugin on WordPress sites, especially those with administrative users accessing the plugin, should prioritize patching or mitigating this issue. Countries with high WordPress adoption and significant digital infrastructure, such as Germany, the UK, France, and the Netherlands, are more likely to be affected.

References

Community reviews

Loading reviews…