Skip to main content
VulnerabilityPublished Updated

CVE-2025-15437: LigeroSmart · Cross-site Scripting

Affects LigeroSmartSource CVE Database V5

0

Public exploit available · CVSS 5.1 Medium.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
GitHubligerosmart/ligerosmartpkg:github/ligerosmart/ligerosmartOther threatsAffected
  • 6.1.0 – 6.1.24
25 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2025-15437, organizations should immediately upgrade LigeroSmart installations to version 6.1.26 or 6.3, where the vulnerability has been patched. In addition to patching, administrators should implement web application firewalls (WAFs) with rules designed to detect and block malicious payloads targeting the REQUEST_URI parameter. Security teams should conduct user awareness training to reduce the risk of users clicking on suspicious links. Employing Content Security Policy (CSP) headers can help limit the impact of XSS by restricting the execution of unauthorized scripts. Regularly audit and monitor web server logs for unusual request patterns that may indicate exploitation attempts. If immediate patching is not feasible, consider temporarily disabling or restricting access to the vulnerable component or applying input validation controls at the network edge. Finally, ensure that session management mechanisms use secure, HttpOnly cookies to reduce the risk of session hijacking.

Description

A vulnerability was found in LigeroSmart up to 6.1.24. This affects an unknown part of the component Environment Variable Handler. Performing a manipulation of the argument REQUEST_URI results in cross site scripting. The attack may be initiated remotely. The exploit has been made public and could be used. Upgrading to version 6.1.26 and 6.3 is able to mitigate this issue. The patch is named 264ac5b2be5b3c673ebd8cb862e673f5d300d9a7. The affected component should be upgraded.

References

Community reviews

Loading reviews…