CVE-2025-15677: GeoDirectory (WordPress plugin) · Cross-Site Scripting (XSS)
Affects GeoDirectory (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 3.5 Low : upgrade to 2.8.110 when convenient.
Data as of 3 Nov 2026, 22:57 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.8.110
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 5 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade GeoDirectory (WordPress plugin) to 2.8.110.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| GeoDirectory | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restrict high-privilege user access to trusted individuals only and monitor for suspicious activity. Avoid granting editor or higher roles to untrusted users. Follow the vendor's updates for an official fix or temporary mitigation.
Description
CVE-2025-15677 is a stored cross-site scripting (XSS) vulnerability in the GeoDirectory WordPress plugin before version 2.8.110. It occurs because the plugin does not properly sanitize and escape a place-category setting before outputting it on an admin page. This allows users with high privileges, such as editors and above, to inject malicious scripts even if the unfiltered_html capability is disabled, for example in multisite WordPress setups.