CVE-2025-15695: Translate WordPress with GTranslate · Cross-Site Scripting (XSS)
Affects Translate WordPress with GTranslateSource CVE Database V5
Not known to be exploited · CVSS 3.5 Low : upgrade to 3.0.10 when convenient.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.0.10
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 11 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Translate WordPress with GTranslate to 3.0.10.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Translate WordPress with GTranslate | Affected
| Fixed in
|
AI-suggested
Upgrade the Translate WordPress with GTranslate plugin to version 3.0.10 or later, where this vulnerability is fixed. No other mitigation guidance is provided; patching is the recommended action.
Description
The Translate WordPress with GTranslate WordPress plugin before 3.0.10 does not validate one of its settings before the bundled front-end scripts build markup from it, allowing users with a role as high as administrator to store JavaScript that runs in the session of any visitor to the site.