Skip to main content
CVE-2026-8106VulnerabilityPublished Updated

A reflected HTML injection vulnerability was identified in the GitHub Enterprise Server Management Console login page

Source GCVE Database

0
Authoritative record:CVE-2026-8106· Medium 5.9

Not known to be exploited · CVSS 5.9 Medium : upgrade to 3.20.2 or 3.19.6 when convenient.

Data as of 27 Oct 2026, 00:14 UTC

CVSS 4.0 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.20.2, 3.19.6
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Enterprise Server to 3.20.2 or 3.19.6.

Affected software

ProductAffectedFixed in
GitHubEnterprise ServerAffected
  • >=3.20.0 <3.20.2
Fixed in
  • 3.20.2
GitHubEnterprise ServerAffected
  • >=3.19.1 <3.19.6
Fixed in
  • 3.19.6

AI-suggested

Upgrade GitHub Enterprise Server to version 3.19.6 or later, or 3.20.2 or later, where the vulnerability has been fixed. No other mitigations are indicated or required as the fix addresses the root cause of improper sanitization.

Description

A reflected HTML injection vulnerability exists in the GitHub Enterprise Server Management Console login page. The flaw involves the redirect_to query parameter on the /setup/unlock endpoint being reflected into an HTML attribute without proper sanitization. This allows an attacker to inject a form element that could capture administrator credentials if the administrator clicks a crafted link and enters their credentials. The vulnerability affects GitHub Enterprise Server versions 3.19.1 through 3.19.5 and 3.20.0 through 3.20.1 and was fixed in versions 3.19.6 and 3.20.2.

References

Community reviews

Loading reviews…