Skip to main content
VulnerabilityPublished Updated

CVE-2026-8080: Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting')

Source GCVE Database

0
Authoritative record:CVE-2026-8080· Medium 6.8

Not known to be exploited · CVSS 6.8 Medium · fixed in 2.5.37 : update affected systems when convenient.

Data as of 27 Oct 2026, 00:57 UTC

CVSS 4.0 base score
6.8Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.5.37
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/U:Green

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

AI-suggested

Upgrade MISP to version 2.5.37 or later, where the old templating engine is no longer accessible and this vulnerability is addressed. Since the vulnerable templating engine is removed in 2.5.38, updating to this or a later version fully mitigates the issue. No additional vendor advisory or patch links are provided, but the version upgrade is the definitive remediation.

Description

MISP versions before 2.5.37 contain a stored cross-site scripting (XSS) vulnerability in the template element attribute handling logic. The vulnerability arises because the application accepts arbitrary values for TemplateElementAttribute type and category fields without validating them against known definitions. This flaw allows an attacker with permission to create or modify template element attributes to store crafted type values that can lead to XSS. The affected old templating engine is not accessible starting from version 2.5.37 and will be removed in version 2.5.38.

References

Community reviews

Loading reviews…