Skip to main content
CVE-2025-2007VulnerabilityPublished Updated

CVE-2025-2007: WP Ultimate CSV Importer – Import CSV, XML & Excel into WordPress · Relative Path Traversal

Affects WP Ultimate CSV Importer – Import CSV, XML & Excel into WordPressSource CVE Database V5

0

Not known to be exploited · CVSS 8.1 High · fixed in 7.20.1 : patch WP Ultimate CSV Importer – Import CSV, XML & Excel into WordPress soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.1% chance of exploitation in 30 days – higher than 67% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.20.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Apr 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Affected software

ProductAffectedFixed in
smackcoders WP Ultimate CSV Importer – Import CSV, XML & Excel into WordPressAffected
  • =0
  • =7.20
Fixed in–

AI-suggested

Upgrade the WP Ultimate CSV Importer plugin to version 7.20.1 or later, where the vulnerability has been patched. Versions up to 7.19 and 7.20 are vulnerable. No other mitigations are indicated by the vendor advisory. Patch status is confirmed by the version history described in the vulnerability details.

Description

The Import Export Suite for CSV and XML Datafeed plugin for WordPress is vulnerable to arbitrary file deletion due to insufficient file path validation in the deleteImage() function in all versions up to, and including, 7.19. This makes it possible for authenticated attackers, with Subscriber-level access and above, to delete arbitrary files on the server, which can easily lead to remote code execution when the right file is deleted (such as wp-config.php). Please note this vulnerability was reintroduced in 7.20, and subsequently patched again in 7.20.1.

References

Community reviews

Loading reviews…