Skip to main content
VulnerabilityPublished Updated

CVE-2025-22121: Linux kernel · ext4: fix out-of-bound read in ext4_xattr_inode_dec_ref_all()

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 8.4 High · fixed in 5.15.0-1103.110~20.04.1 : patch Linux kernel soon.

Data as of 28 Oct 2026, 11:45 UTC

CVSS 3.1 base score
8.4High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.15.0-1103.110~20.04.1, 5.15.0-1110.119~20.04.1, 5.15.0-1103.112~20.04.1 +60
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Apr 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-106.106
Fixed in
  • 6.8.0-106.106
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1050.53
Fixed in
  • 6.8.0-1050.53
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1051.57
Fixed in
  • 6.8.0-1051.57
Ubuntu 24.04 LTSlinux-azure-6.11pkg:deb/ubuntu/linux-azure-6.11?arch=source&distro=nobleOther threatsAffected
  • 6.11.0-1008.8~24.04.1 – 6.11.0-1018.18~24.04.1
7 affected builds
Fixed in–
Ubuntu 24.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1058.65
Fixed in
  • 6.8.0-1058.65

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and has been released in multiple Linux kernel versions starting from 5.15.0-1103.110~20.04.1 and related releases. Users and administrators should update their Linux kernel to one of the fixed versions provided by their distribution. The Ubuntu advisory USN-7594-1 confirms the availability of these fixes. No additional mitigation steps are required beyond applying the official kernel updates.

Description

CVE-2025-22121 is a high-severity vulnerability in the Linux kernel's ext4 filesystem implementation. It involves an out-of-bound read due to a use-after-free bug in the ext4_xattr_inode_dec_ref_all() function. The flaw occurs because ext4_xattr_delete_inode() does not properly validate extended attributes (xattr) in the inode, leading to memory corruption. This issue has been fixed by adding proper validation checks for xattr in the inode, preventing the out-of-bound read.

References

Community reviews

Loading reviews…