CVE-2025-22388: episerver.cms.core · XSS or 'Cross-site Scripting'
Affects episerver.cms.coreSource CVE Database V5
Not known to be exploited · CVSS 5.7 Medium : upgrade to 12.22.0 when convenient.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 30% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 12.22.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 4 Jan 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade Optimizely/episerver.cms.core to 12.22.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
NuGetOptimizely/episerver.cms.corepkg:nuget/Optimizely/episerver.cms.coreOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
1. Upgrade Optimizely EPiServer.CMS.Core to version 12.22.0 or later as soon as the patch is available to fully remediate the vulnerability. 2. Implement strict input validation on all user-supplied data in content editing, link management, and file upload modules to reject or sanitize potentially malicious scripts. 3. Apply context-aware output encoding (e.g., HTML entity encoding) to all dynamic content rendered in web pages to prevent script execution. 4. Enforce the principle of least privilege by limiting user permissions to only those necessary for their roles, reducing the risk of exploitation by low-privilege users. 5. Monitor CMS logs and user activities for unusual behavior indicative of XSS attempts or successful exploitation. 6. Educate content editors and administrators about the risks of injecting untrusted content and encourage cautious handling of user inputs. 7. Consider deploying Web Application Firewalls (WAFs) with rules targeting common XSS attack patterns as an additional layer of defense. 8. Regularly review and update security policies and conduct penetration testing focused on XSS vulnerabilities in CMS environments.
Description
An issue was discovered in Optimizely EPiServer.CMS.Core before 12.22.0. A high-severity Stored Cross-Site Scripting (XSS) vulnerability exists in the CMS, allowing malicious actors to inject and execute arbitrary JavaScript code, potentially compromising user data, escalating privileges, or executing unauthorized actions. The issue exists in multiple areas, including content editing, link management, and file uploads.