Skip to main content
CVE-2025-22390VulnerabilityPublished Updated

CVE-2025-22390: episerver.cms.core · Weak Password Requirements

Affects episerver.cms.coreSource CVE Database V5

0

Not known to be exploited · CVSS 7.5 High : upgrade to 12.32.0 soon.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 12.32.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Jan 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade Optimizely/episerver.cms.core to 12.32.0.

Affected software

ProductAffectedFixed in
NuGetOptimizely/episerver.cms.corepkg:nuget/Optimizely/episerver.cms.coreOther threatsAffected
  • <12.32.0
Fixed in
  • 12.32.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations should immediately assess their use of Optimizely EPiServer.CMS.Core and upgrade to version 12.32.0 or later, where password complexity enforcement is improved. In the absence of an available patch, administrators should implement compensating controls such as enforcing stronger password policies via custom configuration or integration with external authentication providers that mandate complexity and length requirements. Deploying multi-factor authentication (MFA) is critical to reduce the risk of account compromise even if weak passwords are used. Monitoring authentication logs for unusual login attempts, such as repeated failed logins indicative of password spraying, can help detect exploitation attempts early. Additionally, organizations should educate users on creating strong passwords and consider implementing account lockout policies after multiple failed attempts to hinder brute-force attacks. Regular security audits and penetration testing focusing on authentication mechanisms will help identify residual weaknesses.

Description

An issue was discovered in Optimizely EPiServer.CMS.Core before 12.32.0. A medium-severity vulnerability exists in the CMS due to insufficient enforcement of password complexity requirements. The application permits users to set passwords with a minimum length of 6 characters, lacking adequate complexity to resist modern attack techniques such as password spraying or offline password cracking.

References

Community reviews

Loading reviews…