CVE-2025-22604: cacti · OS Command Injection
Affects cactiSource GCVE Database
Not known to be exploited · CVSS 9.1 Critical · fixed in 1.2.29 : patch cacti as a priority.
Data as of 30 Oct 2026, 00:32 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 9.1 |
|---|
- Patch
- Available – fixed in 1.2.29
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 Jan 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Cacti cacti | Affected
| Fixed in– |
AI-suggested
Upgrade Cacti to version 1.2.29 or later, where this vulnerability is fixed. No other mitigation or workaround is indicated.
Description
CVE-2025-22604 is a critical OS command injection vulnerability in Cacti, an open source performance and fault management framework. The flaw exists in the multi-line SNMP result parser, where authenticated users can inject malformed OIDs. These OIDs are processed by specific functions and used as keys in arrays that form part of system commands, enabling command execution. The vulnerability affects Cacti versions up to 1.2.8 and is fixed in version 1.2.29.