CVE-2025-23308: NVIDIA CUDA Toolkit · Heap-based Buffer Overflow
Affects NVIDIA CUDA ToolkitSource CVE Database V5
Not known to be exploited · CVSS 3.3 Low : upgrade to 13.0 when convenient.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 13.0
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 24 Sep 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade NVIDIA CUDA Toolkit to 13.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| NVIDIA NVIDIA CUDA Toolkit | Affected
| Fixed in
|
AI-suggested
To mitigate this vulnerability, organizations should: 1) Avoid running nvdisasm on untrusted or unauthenticated ELF files until an official patch or update to CUDA Toolkit 13.0 or later is applied. 2) Implement strict file validation and sandboxing measures when handling ELF files, ensuring that nvdisasm runs in a restricted environment with minimal privileges. 3) Educate users about the risks of processing untrusted CUDA binaries and enforce policies to prevent execution of nvdisasm on suspicious files. 5) Consider using alternative disassembly or analysis tools that do not exhibit this vulnerability if immediate patching is not possible. 6) Employ endpoint detection and response (EDR) solutions to detect anomalous behavior related to nvdisasm execution.
Description
NVIDIA CUDA Toolkit for all platforms contains a vulnerability in nvdisasm where an attacker may cause a heap-based buffer overflow by getting the user to run nvdisasm on a malicious ELF file. A successful exploit of this vulnerability may lead to arbitrary code execution at the privilege level of the user running nvdisasm.