CVE-2025-23391: SUSE rancher · Incorrect Privilege Assignment
Affects SUSE rancherSource CVE Database V5
Not known to be exploited · CVSS 9.1 Critical · fixed in 2.10.4 : patch SUSE rancher as a priority.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.10.4, 2.9.8, 2.8.14
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 11 Apr 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade rancher/rancher to 2.10.4, 2.9.8 or 2.8.14.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubrancher/rancherpkg:github/rancher/rancherOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Organizations should immediately upgrade affected Rancher instances to the fixed versions: 2.8.14 or later, 2.9.8 or later, and 2.10.4 or later. If you cannot patch yet, restrict network access to Rancher management interfaces to trusted administrators only and monitor for unusual password change activities, especially from Restricted Administrator accounts. Implement strict role-based access controls (RBAC) and audit logs to detect privilege escalation attempts. Consider temporarily disabling or limiting the use of Restricted Administrator roles if feasible. Regularly review and rotate administrator credentials and enforce multi-factor authentication (MFA) where supported. Additionally, conduct thorough security assessments of Kubernetes clusters managed by Rancher to detect any signs of compromise resulting from this vulnerability.
Description
A Incorrect Privilege Assignment vulnerability in SUSE rancher allows a Restricted Administrator to change the password of Administrators and take over their accounts. This issue affects rancher: from 2.8.0 before 2.8.14, from 2.9.0 before 2.9.8, from 2.10.0 before 2.10.4.