Skip to main content
CVE-2025-23408VulnerabilityPublished Updated

CVE-2025-23408: Apache Fineract · Weak Password Requirements

Affects Apache FineractSource CVE Database V5

0

Not known to be exploited · CVSS 8.5 High : upgrade to 1.11.0 soon.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 4.0 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.11.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade org.apache.fineract/fineract to 1.11.0.

Affected software

ProductAffectedFixed in
Mavenorg.apache.fineract/fineractpkg:maven/org.apache.fineract/fineractOther threatsAffected
  • <1.11.0
Fixed in
  • 1.11.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

1. Immediately upgrade Apache Fineract installations to version 1.11.0 or later, preferably the latest 1.13.0 release, to apply the official patch addressing weak password requirements. 2. Implement and enforce strong password policies that require complexity, length, and periodic changes beyond default configurations. 3. Integrate multi-factor authentication (MFA) where possible to add an additional layer of security against compromised credentials. 4. Conduct regular audits of user accounts and authentication logs to detect and respond to suspicious login attempts or brute-force activities. 5. Educate users and administrators about the risks of weak passwords and encourage the use of password managers to generate and store strong credentials. 6. Employ network-level protections such as rate limiting and IP blacklisting to mitigate automated attacks targeting authentication endpoints. 7. Monitor threat intelligence feeds for any emerging exploits related to this CVE to respond promptly if active exploitation is detected.

Description

Weak Password Requirements vulnerability in Apache Fineract. This issue affects Apache Fineract: through 1.10.1. The issue is fixed in version 1.11.0. Users are encouraged to upgrade to version 1.13.0, the latest release.

References

Community reviews

Loading reviews…