Skip to main content
VulnerabilityPublished Updated

CVE-2025-24293: Rails activestorage · Code Injection

Affects Rails activestorageSource CVE Database V5

0

Public exploit available (Metasploit) · CVSS 9.2 Critical : upgrade to 7.1.5.2 or 7.0.2.1 as a priority.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
5.5% chance of exploitation in 30 days – higher than 92% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.1.5.2, 7.0.2.1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: evidence found.

    1 Metasploit module

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Rails activestorage to 7.1.5.2 or 7.0.2.1.

Affected software

ProductAffectedFixed in
RailsactivestorageAffected
  • >=7.0 <7.1.5.2
  • >=8.0 <7.0.2.1
  • =5.2
Fixed in
  • 7.1.5.2
  • 7.0.2.1

AI-suggested

Users should immediately avoid accepting arbitrary user input for image transformation methods or parameters, as this is unsupported and dangerous. Strict validation of all user-supplied transformation methods and parameters must be implemented. Additionally, deploying a strong ImageMagick security policy is recommended to mitigate potential command injection risks.

Description

# Active Storage allowed transformation methods potentially unsafe Active Storage attempts to prevent the use of potentially unsafe image transformation methods and parameters by default. The default allowed list contains three methods allow for the circumvention of the safe defaults which enables potential command injection vulnerabilities in cases where arbitrary user supplied input is accepted as valid transformation methods or parameters. Impact ------ This vulnerability impacts applications that use Active Storage with the image_processing processing gem in addition to mini_magick as the image processor. Vulnerable code will look something similar to this: ``` <%= image_tag blob.variant(params[:t] => params[:v]) %> ``` Where the transformation method or its arguments are untrusted arbitrary input. All users running an affected release should either upgrade or use one of the workarounds immediately. Workarounds ----------- Consuming user supplied input for image transformation methods or their parameters is unsupported behavior and should be considered dangerous. Strict validation of user supplied methods and parameters should be performed as well as having a strong [ImageMagick security policy](https://imagemagick.org/script/security-policy.php) deployed. Credits ------- Thank you [lio346](https://hackerone.com/lio346) for reporting this!

References

Community reviews

Loading reviews…