CVE-2025-24530: phpMyAdmin · Cross-site Scripting
Affects phpMyAdminSource GCVE Database
Not known to be exploited · CVSS 6.4 Medium : upgrade to 5.2.2 when convenient.
Data as of 30 Oct 2026, 00:10 UTC
Thin evidence
One scorer or none| CNA (mitre) | CVSS 3.1 | 6.4 |
|---|
- Patch
- Available – fixed in 5.2.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 23 Jan 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade phpMyAdmin to 5.2.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| phpMyAdmin phpMyAdmin | Affected
| Fixed in
|
AI-suggested
A fix is available in phpMyAdmin version 5.2.2 and later. Users should upgrade to version 5.2.2 or newer to remediate this vulnerability. No other mitigations or temporary workarounds are documented.
Description
A cross-site scripting (XSS) vulnerability exists in phpMyAdmin versions 5.0.0 through before 5.2.2 in the check tables feature. This flaw allows an attacker to craft a table or database name that triggers XSS when processed by phpMyAdmin. The vulnerability has a CVSS score of 6.4, indicating a medium severity level.