CVE-2025-25293: ruby-saml · Uncontrolled Resource Consumption
Affects ruby-samlSource CVE Database V5
Public exploit available · CVSS 7.7 High : upgrade to 1.12.4 as a priority.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 1.5% chance of exploitation in 30 days – higher than 74% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.12.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 12 Mar 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade ruby-saml to 1.12.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| SAML-Toolkits ruby-saml | Affected
| Fixed in
|
AI-suggested
To mitigate CVE-2025-25293, organizations should immediately upgrade ruby-saml to version 1.12.4 or 1.18.0 or later, where the vulnerability is patched. If upgrading is not immediately feasible, implement network-level protections such as rate limiting and filtering of incoming SAML responses to detect and block unusually large or suspicious compressed payloads. Employ Web Application Firewalls (WAFs) with custom rules to monitor and restrict anomalous decompression resource usage. Additionally, review and harden SAML response validation logic to include decompressed size checks and resource usage limits. Monitor system resource metrics closely for unusual spikes during SAML processing. Conduct thorough testing of SAML integrations to ensure that decompression and size validation are robust. Finally, maintain up-to-date inventories of ruby-saml versions in use across all applications and enforce patch management policies to prevent vulnerable versions from remaining in production.
Description
ruby-saml provides security assertion markup language (SAML) single sign-on (SSO) for Ruby. Prior to versions 1.12.4 and 1.18.0, ruby-saml is susceptible to remote Denial of Service (DoS) with compressed SAML responses.ruby-saml uses zlib to decompress SAML responses in case they're compressed. It is possible to bypass the message size check with a compressed assertion since the message size is checked before inflation and not after. This issue may lead to remote Denial of Service (DoS). Versions 1.12.4 and 1.18.0 fix the issue.
References
- github.com/SAML-Toolkits/ruby-saml/security/advisories/GHSA-92rq-c8cf-prrq (opens in a new tab)
- github.com/omniauth/omniauth-saml/security/advisories/GHSA-hw46-3hmr-x9xv (opens in a new tab)
- github.com/SAML-Toolkits/ruby-saml/commit/acac9e9cc0b9a507882c614f25d41f8b47be349a (opens in a new tab)
- github.com/SAML-Toolkits/ruby-saml/commit/e2da4c6dae7dc01a4d9cd221395140a67e2b3eb1 (opens in a new tab)
- about.gitlab.com/releases/2025/03/12/patch-release-gitlab-17-9-2-released (opens in a new tab)
- github.blog/security/sign-in-as-anyone-bypassing-saml-sso-authentication-with-parser-differentials (opens in a new tab)
- github.com/SAML-Toolkits/ruby-saml/releases/tag/v1.12.4 (opens in a new tab)
- github.com/SAML-Toolkits/ruby-saml/releases/tag/v1.18.0 (opens in a new tab)
- securitylab.github.com/advisories/GHSL-2024-355_ruby-saml (opens in a new tab)
- security.netapp.com/advisory/ntap-20250314-0008/ (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/04/msg00011.html (opens in a new tab)