CVE-2025-27800: Optimizely Episerver Content Management System (CMS) · XSS or 'Cross-site Scripting'
Affects Optimizely Episerver Content Management System (CMS)Source CVE Database V5
Not known to be exploited · CVSS 4.8 Medium : upgrade to 12.22.1 or 11.21.4 when convenient.
Data as of 26 Oct 2026, 09:15 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 12.22.1, 11.21.4, 11.37.5 +1
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade episerver.cms.core to 12.22.1 or 11.21.4; episerver.cms.ui to 11.37.5 or 11.37.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
NuGetepiserver.cms.corepkg:nuget/episerver.cms.coreOther threats | Affected
| Fixed in
|
NuGetepiserver.cms.uipkg:nuget/episerver.cms.uiOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
1. 2. Restrict WebAdmin and other high-privilege roles to the minimum necessary personnel and enforce strong authentication mechanisms such as multi-factor authentication (MFA). 3. Monitor and audit dashboard gadget usage, especially the Notes gadget, for unusual or unauthorized content changes. 4. Implement Content Security Policy (CSP) headers to limit the impact of injected scripts if exploitation occurs. 5. Educate administrators about the risks of clicking on dashboard elements and encourage cautious behavior. 6. Consider isolating or disabling non-essential dashboard gadgets until patches are applied. 7. Regularly review and update user permissions to ensure least privilege principles are enforced. 8. Conduct penetration testing and vulnerability scanning focused on CMS administrative interfaces to detect similar issues proactively.
Description
The Episerver Content Management System (CMS) by Optimizely was affected by multiple Stored Cross-Site Scripting (XSS) vulnerabilities. This allowed an authenticated attacker to execute malicious JavaScript code in the victim's browser. The Admin dashboard offered the functionality to add gadgets to the dashboard. This included the "Notes" gadget. An authenticated attacker with the corresponding access rights (such as "WebAdmin") that was impersonating the victim could insert malicious JavaScript code in these notes that would be executed if the victim visited the dashboard. Affected products: Version 11.X: EPiServer.CMS.Core (<11.21.4) with EPiServer.CMS.UI (<11.37.5), Version 12.X: EPiServer.CMS.Core (<12.22.1) with EPiServer.CMS.UI (<11.37.3)